Articles Opera

User reviews Opera

  • No good for Mac 10.6

    You should know that the current version of Opera requires at least Mac OSX 10.7 to run. Why aren't system reqs given here? ... More

    eleanorba
    User name
    eleanorba
    User reviews
    2
Review

Opera